Trouble Accessing Raptitude?

impaled computer

Some readers have reported a popup window and an error when they attempt to access Raptitude.com with Internet Explorer.

The error says:

Internet Explorer cannot open the internet site http://www.raptitude.com.

Operation aborted.

I’ve done a bit of research on this error and it is a well-known problem with Internet Explorer 6 and 7. There seem to be about twenty different causes, none of which seem to be the case for me, and twenty different solutions, none of which worked for me.

I will continue to look into this, but in the mean time there is something easy you can do to fix it:

Stop using Internet Explorer 6 and 7. I was surprised to find that 20% of Raptitude readers still use Internet Explorer.  Most of the world has moved on to the far superior (and FREE) Mozilla Firefox web browser, and I’m really not sure why anyone continues to use IE in any form.  If you need convincing, check out the Top 5 Reasons to Use Firefox and the Top 5 Reasons to Dump Internet Explorer.

I know we all have our preferences though, and I won’t begrudge anybody’s choice of browser.  If you would like to continue to use IE, I strongly recommend upgrading to Internet Explorer 8.  This is also completely free, and IE8 seems to fix this error.

If you are not familiar with Firefox, you really should check it out.  It has been the undisputed browser champion of the world for a few years now, having soundly defeated the clunky and disagreeable Internet Explorer. 70% of Raptitude readers choose Firefox.  That’s more than double all other browsers combined.

Google Chrome is another option.  I have not used it much but its fans certainly love it.

Of course you Mac users have nothing to worry about, as usual.

R

Photo by Don Fulano

Did you like this post? Get Raptitude articles via RSS feed. Or if you prefer, get them by Email. It’s easy, and free!


***

{ 4 Comments }

Positively Present July 1, 2009 at 1:53 pm

Thanks for writing about this because I’ve been having the same problem with my site Hope Springs Internal. I keep getting that error message when I try to open the site and I thought it had to do with the site, but I guess it’s IE that’s the problem. I don’t seem to have as much trouble with IE8 but I’m definitely going to consider switching to Firefox or GoogleCrome. So glad it’s not just me that’s having this problem!

{ Reply }

David July 1, 2009 at 3:12 pm

Yeah I had seen a lot of forum posts about people having this problem with different websites. If you ever have technical problems here, let me know and I’ll look into them.

{ Reply }

Alison | Quest for Balance July 2, 2009 at 6:12 pm

I guess I keep using IE because I’m used to it? Bad reason, I know… but other than a few web sites I visit (ahem!), I haven’t had problems with IE. Also, I like the way it looks… which sort of goes along with being used to the way it looks. For the same reason, I prefer HotMail over Gmail (and no, I’m NOT a luddite!).

That said, your issue w/ IE now seems to be fixed (!)… and I do have FireFox installed for those times I need it or want to see how something looks in it. : )

{ Reply }

David July 3, 2009 at 6:30 am

Luddite! ;)

If it’s not giving you problems you might as well use IE. I do know that some users are still having problems, even with IE8.

Oh, and gmail is so awesome, you really don’t know what you’re missing :)

{ Reply }

Leave a Comment


Raptitude is an independent blog by . Some links on this page may be affiliate links, which means I might earn a commission if you buy certain things I link to. In such cases the cost to the visitor remains the same.